Wednesday, April 1, 2015

AIX: How to get CPU / processor socket and core count for IBM Power server

Here is the command for AIX which shows you the count of processor cards (sockets) installed in your Power server including information about count of cores per one socket. The terminology processor in IBM Power server and AIX world describes core in relation to HW.

Command:
lscfg -vp|grep WAY

Example:
lscfg -vp|grep WAY
      6-WAY  PROC CUOD:
      6-WAY  PROC CUOD: 


Expample shows you that system has two sockets and each has 6 cores, so system has 12 cores.





Do you need to know how many cores - virtual processors are assigned to your LPAR?
This is little bit complicated, because depends on mode (Dedicated, Shared, ...), but generally command lparstat can helps you:

# lparstat -i | egrep "Type|Mode|CPU"
Type                                       : Shared-SMT-4 => LPAR shares processor resources in pool
Mode                                       : Uncapped => LPAR can use cores up to value of "Online Virtual CPUs"
Online Virtual CPUs                        : 3 => maximum number of cores which can be utilized
Maximum Virtual CPUs                       : 6 => maximum number of cores which can be added to using DLPAR
Minimum Virtual CPUs                       : 1 => minimum number of cores which can be removed to using DLPAR
Maximum Physical CPUs in system            : 12 => total number of cores installed in the system
Active Physical CPUs in system             : 12 => total number of cores installed in the system
Active CPUs in Pool                        : 12 => number of active cores in particular pool
Shared Physical CPUs in system             : 12 => number of cores in all pools
Physical CPU Percentage                    : 10.00%
Memory Mode                                : Dedicated
Desired Virtual CPUs                       : 3 => number of virtual processors which are assigned during startup
Power Saving Mode                          : Disabled
Sub Processor Mode                         : -


lsdev command shows you count of virtual processors allocated to your LPAR.
# lsdev -Cc processor
proc0 Available 00-00 Processor
proc4 Available 00-04 Processor
proc8 Available 00-08 Processor



Do you need to know how many threads - logical processors do you have in your LPAR / AIX?

# smtctl

This system is SMT capable.
This system supports up to 4 SMT threads per processor.
SMT is currently enabled.
SMT boot mode is not set.
SMT threads are bound to the same virtual processor.

proc0 has 4 SMT threads.
Bind processor 0 is bound with proc0
Bind processor 1 is bound with proc0
Bind processor 2 is bound with proc0
Bind processor 3 is bound with proc0

proc4 has 4 SMT threads.
Bind processor 4 is bound with proc4
Bind processor 5 is bound with proc4
Bind processor 6 is bound with proc4
Bind processor 7 is bound with proc4

proc8 has 4 SMT threads.
Bind processor 8 is bound with proc8
Bind processor 9 is bound with proc8
Bind processor 10 is bound with proc8
Bind processor 11 is bound with proc8


We have 12 logical processors - threads, four threads per one virtual processor - core.

No comments:

Post a Comment